SmartChef® Help

Gas Grill App Tips

<- BACK TO SmartChef® Help

What operating systems is the SmartChef® Gas Grill App compatible with?

The SmartChef® Gas Grill app is only compatible with Android and Apple smartphones:

iOS- iPhone 4s and newer, iOS 8 and newer

Android- Android 4.4 + (KitKat)  => Api Level 19 (phones only)

Optimized for Galaxy S5 and newer, but all Android Smartphones are covered as long as they're running 4.4+

Can't find what you're looking for?

Chat

Need immediate help?
Chat with a real human.

Monday - Sunday
9:00 AM - 9:00 PM EST

Call

Monday - Friday
9:00 AM – 7:00 PM EST

Saturday
9:00 AM – 3:00 PM EST

Email

Send us an e-mail using our contact form. We'll get back to you within 4 business days.